도록태가 뭔가요
cookis

Recent Comment

'통합설치팩'에 해당되는 글 1건

  1. 2014.04.26 [Hyper-V] Linux Intergration Component
2014.04.26 15:53 softwares/quick reference

Hyper-V 에서 Windows 계열의 OS를 설치 시, Intergration Component를 같이 설치하면 가상 하드웨어(네트워크) 드라이버를 같이 설치하게 되어 최적의 VM Guest의 상태로 운영 됩니다만,-Windows 계열의 (, Linux) OS에서는 이와 같은 IC Linux Kernel 혹은 배포본에 포함 되어있습니다. 하지만, 이 Linux용 IC는 Windows VM과는 다르게 아무리 최신 버전으로 설치를 해도 Degraded 에서 Ok 상태로 올라오지 않습니다.

“저하됨(Degraded)” 으로 표시되는 것과는 다르게, 실제로는 Hyper-V 프로토콜을 통해 백단(backward compatible)에서 호환되어 이용 되고 있으며 이는 다음 Hyper-V 릴리즈 에서는 정상적으로 표기 될 예정이라고 합니다.

실제로, 이 문제가 KB에 발표되기 전에 Windows Azure에서 Ubuntu Linux 인스턴스를 생성하여 확인 했을 때, 동일한 버전의 IC를 사용하고 있었으므로 Linux에 포함되어있는 현재의 버전이 가장 최신 버전의 IC라고 보시면 될 것으로 보입니다.

Cause

The various messages shown in the symptoms section occur because the non-Windows guest integration services may not always have the code to interoperate with the latest Hyper-V protocols. This is due to the fact that Windows release cycles are not in sync with the release cycles of other operating systems. As a hypothetical example, the latest Red Hat Enterprise Linux (RHEL) release may ship in January but the latest Windows release may ship in the following September. Between January and September, the Windows team may upgrade the Hyper-V protocols due to which the RHEL release shipped in January may have integration components that were written based on earlier Hyper-V protocols. Now, when a user tries to run an older RHEL release as a virtual machine on a newer Windows release then they may observe messages suggesting that the RHEL integration components are degraded.

Resolution

Users are hereby advised to ignore all messages and warnings that seem to indicate that no technical support will be provided because integration services for a non-Windows guest virtual machine are degraded. Microsoft will provide technical support even if when such messages are visible while running supported non-Windows guests on Hyper-V. Linux users may review a list of supported distributions on Hyper-V on the following page: Linux Virtual Machines on Hyper-V

Note that it is safe to ignore these messages because Hyper-V protocols are implemented to be backward compatible. Therefore, even if a certain non-Windows guest has integration services that were based off earlier Hyper-V protocols, the guest is expected to run flawlessly on newer Hyper-V releases


references
http://support.microsoft.com/kb/2956569

posted by cookis